Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Tenant ID is not mapping with the login

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Tenant ID is not mapping with the login

    I am having trouble getting Alpha to write the tenantid when it writes information to a table. Just the same, it is not retrieving rows of data based on the tenantid.

    I have 2 databases. One is for user info (including the websecurity tables assigned when setting up web security. The other is for the data. Let’s call them users and data. I then went to AlphaDAO (where I created the table connections) and created 2 new connections with the same names. I selected MultiTenant then the users database. I linked Tenant ID and Session Variable to “tenantid” and I now have 2 other connections called usersmt and datamt. I also have a table called “extendeduserinfo” that has a “userid” and “tenantid” column (among a few other columns).

    Under Web Security I went to “Extended User-info Table” link at the bottom. There, the table name is “extendeduserinfo” and the userid field name is “userid”. I am also using a UX security component template “SecurityFramework-Edit_ExtendedUserInfo.”

    If the Web Security “Security Table Type” (SQL) is set to usersmt, I get an error when it tries to write the websecurity tables. It says “Creating New Web Security Tables Error 0 – Error parsing SQL statement 7 – ‘line 1:1: unexpected token: CREATE’. If I select users (without the mt) it runs fine.

    The paragraph above now has the “users” and not “usersmt” so the tables were created.

    If the “Extended User-info Table” (under Web Security) connection string was usersmt (the new multi-tenant connection), and I publish, refresh, login, and run the UX component, it says “Editing Extended User Information for (login name), however no fields are visible. If I change the connection to users (and not usersmt) it lists every field for that user on the table including tenantid.
    So now I have both security settings set to users because usersmt doesn’t play well with me. Now I have 2 different grids. Grid “nomt” uses the data connection string and Grid “yesmt” uses the datamt connection string. Nomt shows me every row no matter what the tenantid column says. Yesmt shows me nothing no matter if the tenantid column has a name that matches in the “extendedUserInfo” table.

    So now I create a row in each table. Both create, and the tenantid column is blank (not null; just blank) when I look at them in the database. When I view the table again, I get the same result in grid nomt, but in yesmt I get the row I just created, but nothing else. This row has an empty “tenantid” (again, not null; just empty), and the reference table I created has the name “agency” for this login under the tenantid column.

    This was in 'character' in the tenantid. I also modified "myconnection.multitenant.a5xbclass" to correct the quote issue around the wherestatement on line 166. That did not resolve the problem either.

    So then I changed SQL tenantid to integer, and I made companies 1 and 2. Login was mapped to company one, however when I did a query, it returned nothing. When I created a new record with that login (mapped to tenantid 1) it created tenantid 0 for it. It seems as though it is not mapping correctly.

    I hope that all made sense. I am lost and struggling, so help is greatly appreciated. I feel like the answer is simple, and I am overlooking it.

  • #2
    Re: Tenant ID is not mapping with the login

    I don't understand what you are trying to do here. I have not used the extended user info as all of my systems have their own "extended info" built in.

    I do know that trying to change the connection string for a web security table can be a big pain.

    But I would be willing to spend some time looking over your work with a pair of fresh eyes in a team viewer session if you are interested.

    Comment


    • #3
      Re: Tenant ID is not mapping with the login

      I absolutely would be willing and interested in a fresh set of eyes looking at it. I don't doubt that looking at it as long as I have is making my eyes blurry. That would be great.

      I am attempting to create a multi-tenant database (where tenantid is unique to the agency, and the login name maps to the tenantid in an extended user info table). I followed the videos in https://documentation.alphasoftware....Connection.xml and I tried the advice in https://forum.alphasoftware.com/show...antidfieldtype which still seems to have the same issues as this person described in 11-19-2018.

      I must be overlooking something simple (or not so simple) because it is not reading that tenantid based on the login.

      Comment

      Working...
      X