Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Image in MySql table not dispaying in Report

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Image in MySql table not dispaying in Report

    Would appreciate some help please.

    I have an image field in a MySql table. The field is a blob. I can upload the image from a UI and it is stored in the field. When I open the UI later it displays in the UI and also in a grid. I have created a report and included the image field but it does not display when the report is run.

    The image is uploaded as a jpeg to a blob field in my table. I can view the image in the native MySql table but cannot get the image on my report to display.

    I have put a boarder round the field on the report where the image should display so I can see where it should be. But no image.

    I have practiced with Alphasports and can create a report and get an image to display from the Northwind DB. What do I need to do to get the image to work in my report?

    Thanks for any help offered.

    Doula
    (John Wilson)
    John

    Currently Using Alpha ver 12.4.4.4. Build: 4346; Addins: 4889 against MySql databases

    Church Job Finder
    A Church of England Enabling Recruitment Partner "Right People, Right Place, Right Time"

  • #2
    Re: Image in MySql table not dispaying in Report

    John,

    See this http://wiki.alphasoftware.com/How+to...ay+in+a+report
    Frank

    Tell me and I'll forget; show me and I may remember; involve me and I'll understand

    Comment


    • #3
      Re: Image in MySql table not dispaying in Report

      Hi Frank,

      Thanks for link. I hope this will work as the in the wiki it says, "If you have images in a BLOB field of a SQL table and try to display them in a report, you might see the field name display on the report instead of the images".

      The issue is that we can see the photo in a grid but nothing at all in the report, not even the field name.

      Watch this space.
      Regards
      Keith Hubert
      Alpha Guild Member
      London.
      KHDB Management Systems
      Skype = keith.hubert


      For your day-to-day Needs, you Need an Alpha Database!

      Comment


      • #4
        Re: Image in MySql table not dispaying in Report

        Hi Frank .................

        Thanks for the advice ......... worked a treat. Keith and I can now progress with the reports for our Call Managment Information System.

        Cheers

        Doula
        (John Wilson)
        John

        Currently Using Alpha ver 12.4.4.4. Build: 4346; Addins: 4889 against MySql databases

        Church Job Finder
        A Church of England Enabling Recruitment Partner "Right People, Right Place, Right Time"

        Comment


        • #5
          Re: Image in MySql table not dispaying in Report

          Frank, if I'm not mistaken, the doc on this says it only applies to desktop apps...is there a solution for mobile apps generating reports with each of the photos, stored in a MySQL table, missing from the report?

          Comment


          • #6
            Re: Image in MySql table not dispaying in Report

            Hi Simon,

            The doc does not make any mention that this applies only to desk top.
            In the Specify Data Source dialog, click on Advanced Options near the bottom of the dialog. On the Advanced Options dialog check Override field definitions of selected fields and press the Field Definitions button. In the Field Definitions dialog, pick the field you want to override and press the Edit field definition button to make the field convert to the desired type in the temporary data table created for the report.
            As mentioned above, this tip from Frank did the job.

            Try it and see what you get.
            Regards
            Keith Hubert
            Alpha Guild Member
            London.
            KHDB Management Systems
            Skype = keith.hubert


            For your day-to-day Needs, you Need an Alpha Database!

            Comment


            • #7
              Re: Image in MySql table not dispaying in Report

              Indeed, Keith - the wiki doc says nothing; it was the AA Help page, Override Field Definitions Dialog, that has the line:

              Limitations
              Desktop applications only

              That being said, I tried it anyway (Frank's advice seems always sound) and it does work great! I was just about to "Nevermind" it on this thread but you got here first :) Someone might want to update the Help on that...

              Actually, it works on the Live Preview anyway - still can't get the complete report to reveal itself on the phone. But that is probably a different problem.

              Comment

              Working...
              X