Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

phonegap security login not working?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • phonegap security login not working?

    Hi there I have a mobile UX working brilliantly in a browser. I cant get it to work in a phonegap build. It has security enabled and seems to install ok. The component uses a UX component embedded in a security enabled UX component.

    I start the app in my phone (Samsung S5) I enter the security credentials ok but when I click the login button - nothing happens. It works perfectly in a web browser and transitions to the embedded UX component but in the phonegap build...nothing.

    I've read in a few threads by A5 experts that the security is supposed to work in phonegap ...?

    I've attached the additional files that I think I need, I have no idea how to use the debugger...has anyone else been bashing their head against a wall for a couple of hours on this issue and solved it?

    EDIT - I was working from home and out of habit using my internal IP address for the phonegap builder, not my external one. The security works now but the save button does not...I'll keep bashing away on this next issue
    Last edited by brad.lindsay69@gmail.com; 07-08-2014, 07:41 PM. Reason: found one solutions

  • #2
    Re: phonegap security login not working?

    I love being a noob. I've burnt another 5 hours and I cant get the save button to work on my main app (security looks fine). As I understand this the app, (and the forum threads I've reread 100 times) it is not making ajax call back.

    I have created a whole new app to test the functionality and packaged it the PG builder and I can get this to work. Yeah.

    The settings look identical but there is obviously something I am missing as I cant get the main app I have spent days building - to save a record (works fine as a web app - and is cool!)

    I copied some javascript code from one of the vids into the onAjaxCallbackNotAvailable client side event handler that looks like this.

    if(typeof window.plugins == 'object') {
    window.plugins.toast.showSortCenter('Device is currently offline');
    } else {
    alert('Device is off line at this moment'):
    }

    I dont even know what this means (I bought A5 as a RAD code free development tool and am now donkey deep in different programming languages, don't get me wrong I love it but its frustrating to the max at times) but sure enough the message 'Device is offline at this moment' pops up when I try to save the record - I cant figure out why when I can get the test app I built to work. Sigh.
    Last edited by brad.lindsay69@gmail.com; 07-09-2014, 03:57 PM.

    Comment


    • #3
      Re: phonegap security login not working?

      I finally got it to work then it didnt here is where I am at.

      1) I deleted the afterDialogValidate, ExecuteServerSideAction save data action script, created a new one and republished it, it finally worked after many hours I was able to save a record!!!
      2) I was so excited I tried again, but this time it didn't work, I got an error (I had debugging on the UX component in the ExecuteServerSideAction genie turned on) saying I had a duplicate key. I discovered the form had not refreshed (it refreshes automatically in the web app as I have the Enter Another Record option selected in the After Submit Action in the action script edit thingy)
      3) So then I added a reset.form() after save javascript function (still in the genie) and went back to my app to try this but now I cant connect again.Sigh
      4) I have tried deleting and recreating the ExecuteServerSideAction many times and then testing in my app after each attempt, occasionally (randomly?) after one of these deletion/recreation attempts the app will work and save one record then not work again, the reset.refresh() did not work.

      So I can make a data bound PG app from scratch with security and make it work (security is good and it saves new records)but I am still bashing my head against a brick wall to understand why the actual app I had previously spent days building wont save (security looks to be ok)...

      Am I the only one having these issues, one of the other threads indicated someone else was having intermittent success but never nailed a solution...

      http://msgboard.alphasoftware.com/alphaforum/showthread.php?110301-PhoneGap-How-to-get-my-intranet-Alpha-app-to-work&highlight=phonegap+ajax

      Comment

      Working...
      X