Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

v10 Beta completely stopped working?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Re: v10 Beta completely stopped working?

    Originally posted by drgarytraub View Post
    Well, now, if I create a new grid from scratch, then all of the features I mentioned above do indeed work - and wow, very impressive!

    But surely, I am not going to have to rebuild all my grids am I? Is there another setting I need to check?

    Gary
    Have you got the latest build, and if yes, have you spotted the option in the menu to recompile all components in your app?

    Also I had to re-do the odd grid at the beginning especially where i had used custom fields, but with later builds did not have this problem as custom fields now work for me. Plus it is so much faster to build a new grid from scratch anyway.

    You may want to Copy any grid event code you have written into a text file and then click the link to insert the the default event code, then put your own xbasic back in, and modify according to any new info in the default text. A lot of customisation has become very much easier to do now, this includes formatting overrides you previously had to use custom fields for.

    Comment


    • #32
      Re: v10 Beta completely stopped working?

      Hi Andrea,

      Yes I do have the latest build. And thanks for your suggestions. I went ahead and recompiled as you suggested, but no luck. Thus, I have begun to rebuild the grid and I do see how much easier it is to develop than in prior versions.

      I am concerned though about the bugs causing problems for users of my application. Do you use v10 beta for live applications at this point? I would prefer to keep v9 and v10 beta separate for now. Do you know if I can have 2 separate installations of v9 (one with v10 beta, and the other without)?

      Gary
      Gary S. Traub, Ph.D.

      Comment


      • #33
        Re: v10 Beta completely stopped working?

        Not sure who has what info, so I have to purposely be vague in the name of confidentiality, but go check the info you were given about V10. There is a way to switch the V10 mode on and off.
        Frank R

        Comment


        • #34
          Re: v10 Beta completely stopped working?

          Hi Frank,

          Yes, I know how to do that, but even if we turn the v10 features off, we would still be modifying code within grids, whether it is used or not (based on v10 features turned on or not) - so I wouldn't think it would be a good idea to make changes with v10 to files that we would want to use in v9. Am I correct?

          Gary
          Gary S. Traub, Ph.D.

          Comment


          • #35
            Re: v10 Beta completely stopped working?

            Originally posted by drgarytraub View Post
            Hi Frank,

            Yes, I know how to do that, but even if we turn the v10 features off, we would still be modifying code within grids, whether it is used or not (based on v10 features turned on or not) - so I wouldn't think it would be a good idea to make changes with v10 to files that we would want to use in v9. Am I correct?

            Gary
            yes
            Al Buchholz
            Bookwood Systems, LTD
            Weekly QReportBuilder Webinars Thursday 1 pm CST

            Occam's Razor - KISS
            Normalize till it hurts - De-normalize till it works.
            Advice offered and questions asked in the spirit of learning how to fish is better than someone giving you a fish.
            When we triage a problem it is much easier to read sample systems than to read a mind.

            Comment


            • #36
              Re: v10 Beta completely stopped working?

              what I did was to copy the a5v9 folder on my program files folder and rename it to a5v10 and there is where I put the v10 files. So I have two separate programs now
              Cheers
              Mauricio

              Comment


              • #37
                Re: v10 Beta completely stopped working?

                Mauricio,

                Did you re-install v9 in to another folder? and then put the beta stuff in there?

                Gary
                Gary S. Traub, Ph.D.

                Comment


                • #38
                  Re: v10 Beta completely stopped working?

                  I just did a copy paste to the folder, but probably it would be better to re-instal alpha in another folder.
                  Cheers
                  Mauricio

                  Comment


                  • #39
                    Re: v10 Beta completely stopped working?

                    Gary,

                    see this post here:

                    http://msgboard.alphasoftware.com/al...50&postcount=3

                    So my advice:

                    -Use a different Program folder, AND,
                    -Use different data folder (or when SQL: A different schema).
                    -Also, better to publish to a different folder also, so you do not overwrite V9 with V10 and v.v.

                    Comment


                    • #40
                      Re: v10 Beta completely stopped working?

                      Thanks guys. That is VERY helpful!

                      Gary
                      Gary S. Traub, Ph.D.

                      Comment

                      Working...
                      X