Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Upload user defined problem when uplading multiple files

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Upload user defined problem when uplading multiple files

    Hello.

    First of all I won't mind if nobody will answer to my thread, it already happened 4 out of 4 times, so I'm used to it. Still this forum is a gold mine for me and I will keep trying to get answers.

    I built a button for UPLOADING FILES and I checked ALLOW MULTIPLE FILE UPLOAD.

    The problem is I can't upload more than 5 or 6 files at one time or can' t upload large files (relatively, I tried a 35 Mb file with no success).

    I even changed the REQUEST BODY from 60 to 480 as suggested by Steve W in another thread.

    I get the following error :


    The connection was reset


    The connection to the server was reset while the page was loading.

    The site could be temporarily unavailable or too busy. Try again in a few
    moments.
    If you are unable to load any pages, check your computer's network
    connection.
    If your computer or network is protected by a firewall or proxy, make sure
    that Firefox is permitted to access the Web.


    Like I said, I can upload not more than 6 files at one time and I need to be able to upload 20 30 at once.

    Thanks for the person or persons who will be able to help.

    Mike.

  • #2
    Re: Upload user defined problem when uplading multiple files

    The latest pre-release build has significant changes to allow for larger file uploads. See the release notes HERE for more information. Scroll down to the topic under Features for "Application Server - File Upload - Maximum Size".

    You will still be limited by the server computer as very large files may be larger that available memory on the computer (or VPS). If you set the upper limit greater than the capabilities of the server computer, you may get an out of memory error. This upper limit will vary from one computer to another and can only be determined by testing. Internet applications may also have a practical limit as most providers have much slower upload speeds than download speeds and very large files may take a long time to upload.

    Comment


    • #3
      Re: Upload user defined problem when uplading multiple files

      First reply.

      It is alive. :)

      Thanks for your response Jerry and your link for App Server info. I can't seem to find "Application Server Settings - Maximum POST body size" though. I only found Request Body which, as Steve W suggested, was changed from 60 to 480, with no luck, again.

      My main problem is not the upload of large files (it still is a problem), but I can't upload more than 5 or 6 files when I push the UPLOAD button.

      Thanks again for replaying.

      Mike.

      P.S. I looked to every (or many) upload problems that were put to discussion on the forum before starting this thread.

      Comment


      • #4
        Re: Upload user defined problem when uplading multiple files

        The setting Jerry mentioned is only in the prerelease. An official patch with the changes is not yet available.

        Your multiple files will be uploaded in a single POST, so their sizes are combined. How large are they in total?

        Lenny Forziati
        Vice President, Internet Products and Technical Services
        Alpha Software Corporation

        Comment


        • #5
          Re: Upload user defined problem when uplading multiple files

          Hey Lenny.

          The 11 (eleven) files have a total of 9.3 Mb combined (anyway less than 10 Mb). It is a bunch of bank papers, doc's and pdf's combined ...

          Regards.

          Mike.

          Comment


          • #6
            Re: Upload user defined problem when uplading multiple files

            You should also check the server's access and error logs for additional information. If they are logging a 408 status, the upload is timing out and you need to further increase the body timeout value.

            Have you tried the prerelease yet? It has significant improvements to file uploads.

            Lenny Forziati
            Vice President, Internet Products and Technical Services
            Alpha Software Corporation

            Comment


            • #7
              Re: Upload user defined problem when uplading multiple files

              Hey mr. Lenny.

              Now I see that you are VP.

              No replays for my other threads and all of a sudden a VP is guiding me ??

              I am honored.

              I will try later your suggestions.

              Thanks very much.

              Mike.
              Last edited by zumik; 04-20-2012, 02:07 PM.

              Comment


              • #8
                Re: Upload user defined problem when uplading multiple files

                Hey again.

                I don't know about the prerelease but I have the latest version on A5 on my PC and A5 Server on ZebraHost platform.

                I checked the Enabled Server Logging though and I got this (along with a bunch on errors related to CSS files missing) :

                [Sat Apr 21 10:54:16 2012] [error] [client xx.xx.xx.152] Connection reset by peer
                [Sat Apr 21 10:54:28 2012] [error] [client xx.xx.xx.152] Connection reset by peer

                xx.xx.xx.152 being my IP.

                So maybe my PC/router is doing something wrong ?

                Regards.

                Mike

                Comment


                • #9
                  Re: Upload user defined problem when uplading multiple files

                  The pre-release builds can be found HERE. There are major changes to the file upload process between the last release build and the latest pre-release. Depending on the resources of the computer, uploading up to 100 mb should be no problem at all in the newest pre-release, and some systems may allow up to 500 mb+

                  The connection reset by peer is very common with IE and no cause for concern.

                  Comment


                  • #10
                    Re: Upload user defined problem when uplading multiple files

                    A bunch of thanks to all who helped me with this problem and as many thanks to all the members who also helped in others matters.

                    Jerry, I will try what you suggested and I hope it works.

                    Thanks again.

                    Mike/

                    Comment


                    • #11
                      Re: Upload user defined problem when uplading multiple files

                      Sorry for blaming Alpha.

                      It turned out I was lazy and didn't try uploading files using other browser than Firefox. (Thanks Jerry for directions with the IE, it turned out to a solution).
                      I tried uploading 40 (forty) files at once yesterday using IE and ... SUCCESS.

                      So not an ALPHA issue, but thanks to all.

                      Thread closed.

                      Mike out

                      Update:

                      It seems that my settings for Windows Firewall haven't been listening to me when I set it OFF for home networks and ON for PUBLIC. It changed back to ON for both and that was the problem. I set it OFF for home net and ... again ... SUCCESS with FIREFOX also.

                      So NOT a FIREFOX issue EITHER.

                      Mike out again.
                      Last edited by zumik; 04-23-2012, 03:21 AM.

                      Comment

                      Working...
                      X