Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook



The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic

Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.

If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.

Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.

Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Local Profile not publishing to webroot folder

  • Filter
  • Time
  • Show
Clear All
new posts

    Local Profile not publishing to webroot folder

    I need help modifying a web project. I have a web project working and the last time I edited it was two years ago. Today I am trying to add a new grid and re-publish. I successfully saved the web project but I can't publish successfully.

    I am working on the same computer that is running the server so I am using the "Local Webroot" profile. When I went to publish I got this error message:

    The folder G:\A5Webroot\CrackerMill does not exist. Create folder?

    Quite some time ago I changed the webroot folder to "S:\A59Webroot\CrackerMill" using the server configuration settings. But apparently this "local webroot" profile still has the old webroot path embedded in it's settings. I have attempted editing the local profile path using the "edit" button inside the "web project profiles" window. When I attempt to select the new webroot folder using the browser/explorer path tree from this dialog all I get is the following error:

    "The target folder must be inside the webroot folder."

    I am stumped. I tried adding a new folder "inside" the S:\A59Webroot\CrackerMill and then I went back to select that new folder. Same error. I cannot figure out how to publish to my local server using my current webroot folder, as set in the Application Server.

    The alias in the Local Webroot profile is set to something like "get_path". Apparently this path is still set to the old webroot folder I was using two years ago when I first created this web project.

    How do I set the path in this existing web project to publish to my current webroot folder?

    Thank you,

    Re: Local Profile not publishing to webroot folder

    I attempted to solve this publishing problem by creating a new profile. I got this error message:

    The folder 'G:\A5Webroot\S:\A59Webroot\Crackermill\Cardfile' does not exist. Create folder?

    It appears that the "G\A5Webroot" folder is hard-coded as the default webroot folder somewhere. But I don't know how to change it.

    Is this default webroot folder assigned somehow at the time I first create the web project? Can it be changed or do I have to start over of I want to use my now current webroot folder?

    Again, I created this web project over two years ago. I have since changed my webroot folder assignment. I am now trying to make a few changes to this two-year-old web project but I can't complete the publishing action due a conflict in file path names. The old webroot folder no longer exists.

    I've been reading the forum. So far, nothing specific to my problem has shed any light. Maybe I should just re-build the old webroot directory? Seems odd that I can't change the webroot folder location. I'm missing something. Please help.

    Thank you,


      Re: Local Profile not publishing to webroot folder

      I have been reading about aliases but everything seems to be focused on where to locate the data files. My problem seems more about where to PUBLISH the web project. Where do I look to change a publishing location?

      I changed the webroot location in the Application Server. The former location was set to "G:\A5Webroot". The new location is "S:\A59Webroot\CrackerMill". I was able to move the published files from the old location to the new location and everything still works fine in the browser.

      But now I am trying to modify and republish the same project and it is stuck with a pointer to the old webroot location and will not accept any other path locations. Why? Why can't I change the webroot location in the profile? There is a field in the profile editor and it allows me to browse to a new location or type in a location. But it always ends in a message asking me to create a folder using the OLD webroot location. I do not want to publish to the OLD location. I want to publish to the NEW location. How?

      Is this in the registry somewhere?

      I am developing and publishing on the local machine. This machine is running the Application Server and is reachable from any other machine on the LAN. It is working. But I cannot edit the web project and re-publish. Don't know why. Getting frustrated. Reading a LOT and getting nowhere. I can't see where the setting is changed. Perhaps I am not allowed to change the webroot location once I start building web projects. Seems odd.



        Re: Local Profile not publishing to webroot folder

        Hi Sean
        The answer is in the help utility under: Configuring the Application Server. And the The Document Root folder can be any folder on any drive. But the location of that folder is set in the settings for the Application server not in the profiles utility. I did not try to change mine but the instructions do describe what you want to do.
        Hope this helps


          Re: Local Profile not publishing to webroot folder

          Thank you Irwin,

          I did read that page, and several others. But my problem is not understanding where to set the webroot folder. My problem is that no matter where I set the webroot using the the settings inside the Application Server, when I go to publish, the wizard insists on using an old folder location. The folder location supplied by the wizard does not match the folder location I have set in the AS.

          There are two different things going on. I am trying to figure out why the publishing wizard is not picking up the webroot location as it is set in the AS.

          The documents seem to indicate that the publishing wizard will only use the folder set as webroot in the AS settings. But this is not the case. The wizard is not seeing the correct setting and is using a location that is somehow hard-coded into it's script. I don;t know if this is how it is working. I am just making assumptions. All I know is that I can't get the wizard to publish to the folder I want it to publish to.



            Re: Local Profile not publishing to webroot folder

            You need to set the webroot using the Application Server Control Panel within Alpha Five. If you also have the stand-alone Application Server installed, publishing will NOT read those settings.

            Lenny Forziati
            Vice President, Internet Products and Technical Services
            Alpha Software Corporation


              Re: Local Profile not publishing to webroot folder

              Thank you Lenny,

              I'll try that. In the meantime I went ahead and published to the wrong folder and then copied everything over to the right folder. It works as a work-around. Now, off to try your tip.



                Re: Local Profile not publishing to webroot folder

                I guess I don't know where to find this Application Server Control Panel from within Alpha Five. All the screens I am seeing I have seen before.No matter what I do I cannot reset the correct document root folder from within my web project from within Alpha Five. The only place I have found to enter a directory is in the Profile settings. That does not work for me. I can find no other place to enter the correct document root directory to force the publishing wizard to publish to my preferred folder.

                I have the following windows within Alpha Five:

                BCI_Active_v91.adb: Control Panel (this is my database upon which I am trying to edit a web project)

                Web Projects Control Panel (this is my web project I am trying to edit and re-publish)

                When I open the database the "Application Server" button on the top toolbar has a red light. When I clicked on it I got an error stating I already have a server running on my port 8080 (the port I chose to use for my Application Server). I then shut down the AS. I went back to my database toolbar and clicked on the red light again. This time I did not get an error message and the light turns green.

                From here I can not find any "control panel" from which to set my document root folder. Apparently I have a different server instance running but the results are the same. I can't publish to my chosen folder.



                  Re: Local Profile not publishing to webroot folder

                  Okay, I think I found it. There is a menu entry named Web|Application Server. When I clicked on that I found my old document root setting. This screen looks identical to the screen on my AS settings but is apparently the "control panel" for the instance of the server under the control of the A5 program.

                  I did not notice anywhere in my reading where It discussed the fact that having the AS on the same machine as the development database will require the use of two distinct instances of the server, one - the instance started and controlled from withing A5, and two - the actual Application Server program that stands on it's own.

                  I have to use the A5 instance for the publishing wizard. Then use the standalone version to allow other users to actually access the web pages I created using the A5 program. I must have missed this in the documentation. Or is it really this confusing?



                    Re: Local Profile not publishing to webroot folder

                    It's working now. Thank you Lenny.

                    Somehow I was under the impression that if I was using the AS program I did not need to use the server built into the A5 program. Now I know I was wrong. I hope I can remember this the next time I make a change to the web project!