Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Report Does Not Contain Any Records

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Report Does Not Contain Any Records

    We are having an odd problem. We are creating a purchase order.
    I run a script which creates a filter and then runs a report preview.
    The report preview comes up on the screen. We look at everything and determine correctness.
    We then press the print button in the toolbar.

    99% of the time, the report prints fine. But 1% of the time, we get an error message,
    "Report Does Not Contain Any Records"

    But the preview did contain a record, the correct record.
    If there was no record, then I would think the preview would state that message.

    Has anyone else ever seen this?

    Code:
    DIM SHARED vcPO_Num AS c
    vcPO_Num = parentform:Ptransno.value
    
    query.filter = "Ptransno = Var->vcPO_Num"
    query.order = "recno()"
    'replace variables in the filter with their actual values	
    query.filter = convert_expression(query.filter,"V")
    
    :Report.Preview("PO",query.filter,query.order)
    
    end
    Alpha 5 Version 11
    AA Build 2999, Build 4269, Current Build
    DBF's and MySql
    Desktop, Web on the Desktop and WEB

    Ron Anusiewicz

  • #2
    Re: Report Does Not Contain Any Records

    Whenever I encounter this message, without giving it too much thought and without delving too much into the underlying cause (which I think it's a stack overflow), I close and re-open alpha and everything is well.

    Comment


    • #3
      Re: Report Does Not Contain Any Records

      Closing and re-opening alpha does correct the problem. It's just annoying as the report prints. When they grab the paper and look at it, instead of the PO, in the middle of the paper is the message Report Does Not Contain Any Records.
      Alpha 5 Version 11
      AA Build 2999, Build 4269, Current Build
      DBF's and MySql
      Desktop, Web on the Desktop and WEB

      Ron Anusiewicz

      Comment


      • #4
        Re: Report Does Not Contain Any Records

        You might try and clear or increase the computer cache or try a printer with a larger sprool memory. I never tried any of this as this does not happen that frequently

        Comment


        • #5
          Re: Report Does Not Contain Any Records

          Using the query dot variables invokes the 4 query slot rule and may be causing you to lose your query when the slots are filled. Try just defining a filter and order with local variables in your script. Note you don't need to specify an order expression since leaving it blank or undefined defaults to recno().

          DIM SHARED vcPO_Num AS c
          vcPO_Num = parentform:Ptransno.value

          filter = convert_expression("Ptransno = "+quote(Var->vcPO_Num),"V")
          :Report.Preview("PO",filter)

          end
          Robin

          Discernment is not needed in things that differ, but in those things that appear to be the same. - Miles Sanford

          Comment


          • #6
            Re: Report Does Not Contain Any Records

            I've never heard of the 4 query slot rule. Can you explain?

            Call it being lazy, but many times I will use the genie to write code for me.
            Sometimes the genie puts in a lot of extra stuff. I will try the following code and see if the problem goes away.

            Thanks

            Code:
            ''Get 'Value' property of 'Ptransno' in Form 'PO' .
            DIM SHARED vcPO_Num AS c
            vcPO_Num = parentform:Ptransno.value
            query.filter = "Ptransno = " + s_quote(Var->vcPO_Num)
            
            :Report.Preview("PO",query.filter)
            
            end
            Alpha 5 Version 11
            AA Build 2999, Build 4269, Current Build
            DBF's and MySql
            Desktop, Web on the Desktop and WEB

            Ron Anusiewicz

            Comment


            • #7
              Re: Report Does Not Contain Any Records

              You could also try clearing the query.filter variable before resetting it or after the preview runs to force a new query.

              Read more here
              Robin

              Discernment is not needed in things that differ, but in those things that appear to be the same. - Miles Sanford

              Comment


              • #8
                Re: Report Does Not Contain Any Records

                Don't forget to compact after working on a report.
                Dave Mason
                [email protected]
                Skype is dave.mason46

                Comment


                • #9
                  Re: Report Does Not Contain Any Records

                  Originally posted by Ronald Anusiewicz View Post
                  I've never heard of the 4 query slot rule. Can you explain?

                  Call it being lazy, but many times I will use the genie to write code for me.
                  Sometimes the genie puts in a lot of extra stuff. I will try the following code and see if the problem goes away.

                  Thanks

                  Code:
                  ''Get 'Value' property of 'Ptransno' in Form 'PO' .
                  DIM SHARED vcPO_Num AS c
                  vcPO_Num = parentform:Ptransno.value
                  query.filter = "Ptransno = " + s_quote(Var->vcPO_Num)
                  
                  :Report.Preview("PO",query.filter)
                  
                  end
                  Changing query.filter in this code to any other variable would remove any possible conflict and confusion.

                  Foo.filter
                  Nothing.filter
                  My_report_filter
                  There can be only one.

                  Comment


                  • #10
                    Re: Report Does Not Contain Any Records

                    Tom Cone and I looked at this and we can't explain why this could happen.
                    I did simply the code to the following:

                    Code:
                    ''Get 'Value' property of 'Ptransno' in Form 'PO' .
                    DIM SHARED vcPO_Num AS c
                    vcPO_Num = parentform:Ptransno.value
                    :Report.Preview("PO","Ptransno = " + s_quote(Var->vcPO_Num))
                    
                    end
                    The preview always works. It's after the print toolbar button is pushed that
                    the error will sometimes occur. This button is the standard print button that
                    alpha supplies.

                    We'll see if this could correct the problem. It happens enough that after a week
                    I should know whether this fixes the problem or not.
                    Alpha 5 Version 11
                    AA Build 2999, Build 4269, Current Build
                    DBF's and MySql
                    Desktop, Web on the Desktop and WEB

                    Ron Anusiewicz

                    Comment


                    • #11
                      Re: Report Does Not Contain Any Records

                      It's 16 slots and in reality it allows for a little more.

                      Comment


                      • #12
                        Re: Report Does Not Contain Any Records

                        16 slots total, but only 4 per table
                        Robin

                        Discernment is not needed in things that differ, but in those things that appear to be the same. - Miles Sanford

                        Comment


                        • #13
                          Re: Report Does Not Contain Any Records

                          Figured out what's going on here finally. The user having the issue would
                          print the last couple of pages of a multi page report. Then later would try to print
                          a single page report. They failed to note that Alpha retained the previous print
                          settings. Alpha doesn't appear to generate an on screen warning message. Instead,
                          a page gets printed with the message, "Report Does Not Contain Any Records".

                          Print.PNG
                          Alpha 5 Version 11
                          AA Build 2999, Build 4269, Current Build
                          DBF's and MySql
                          Desktop, Web on the Desktop and WEB

                          Ron Anusiewicz

                          Comment


                          • #14
                            Re: Report Does Not Contain Any Records

                            Hi Ron,
                            That's odd that the setting was retained - unless they changed the print setup from the file menu instead of the printer prompt. Been there, done that!
                            Robin

                            Discernment is not needed in things that differ, but in those things that appear to be the same. - Miles Sanford

                            Comment

                            Working...
                            X