Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

set / table not found

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • set / table not found

    if i right click a table or set and click update indexes, i get an error message 'set not found 'setname' then alpha updates the indexes and all is ok.

    not causing any direct problems that i know of, but wondered if anyone else has this and is there a way to fix it?

    thanks

  • #2
    Re: set / table not found

    Perhaps something crashed earlier on during your development session leaving Alpha in an unstable state. Suggest shutting down Alpha. Restarting Alpha. Compacting the database.

    Comment


    • #3
      Re: set / table not found

      tom,

      this has been around for a little while for me and have shut down, compacted etc quite a few times.

      Comment


      • #4
        Re: set / table not found

        richard,

        it sounds like you need to rebuild that set or possibly copy the set to a new name makind sure you have any associated forms/reports/etc also copied. once the old set is deleted then rename the new one to the old name. There may be some corruption in the set??


        I would rebuild from scratch with a new name and do a copy to of all reports/forms/scripts/etc then rename it to the ols set name if needed.

        Hope it helps.

        .
        Dave Mason
        [email protected]
        Skype is dave.mason46

        Comment


        • #5
          Re: set / table not found

          Richard, compacting repeatedly is not necessary. If compacting once doesn't solve the problem something else is amiss. You aren't using illegal characters in table, set, or index names are you?

          Comment


          • #6
            Re: set / table not found

            dave, it does help and i have considered, but avoided as some of these sets have quite a few forms, reports etc.

            tom, i use underscores, i thought these would be ok.... i have just updated an index on a table with an uderscore and it was ok.

            i must have a corruption somewhere.

            thanks for the advice

            Comment


            • #7
              Re: set / table not found

              more...

              i check one set that gave the error message, i checked each table in the set and they all are ok. i checked the set indexes and there are no illegal characters.

              Comment


              • #8
                Re: set / table not found

                Was this issue ever resolved??? I don't see an answer here...

                All of a sudden I am getting the "Set not found..." error on every set and on every machine.

                I started having problems with forced terminations and thought that a reindex or pack would help. Nothing seems to work

                I have tried to copy the sets to another database - tried duplcating the database, tried reindexing and packing individually, tried working fromt eh server location

                All machines report set not found - How did you fix it??

                Comment


                • #9
                  Re: set / table not found

                  it never got resolved, however, i have been trailing v10 for the last few days and i have just tested this out in v10 and no problems at all.

                  i did move my app between my work and home a lot and maybe this caused the issue.

                  Comment


                  • #10
                    Re: set / table not found

                    Thanks Richard,
                    I am using it as is and it seems to be working OK. I tried everything I could think of (copy to new database, copy to ne files, edit the sets, etc) but just keep getting the error and yet the indexes update just fine.

                    I have V10 also but can't use it until i go through and redo all of my forms as many of them do wierd things since Alpha has changed the browse features in version 9. I am still running an old version 9 because the new browses wreaked havoc in our system.

                    I feel like I am losing control as there is a lot of data and it seems that the new versions tend to be less backward compatable than they are supposed to be. We have a lot of years of data that I cannot afford to lose and my time to go in and rewrite hundreeds of forms and browses while doing the paying work is somewhat limited.

                    Best,
                    Dan

                    Comment

                    Working...
                    X