Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Posting Field Rule

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Posting Field Rule

    Hi,

    I found my Posting field rule fires on strange result.
    I have the posting rules from PO_Item table and I changed several way to make it happen but I cannot find the problem.

    The Products_id of products table is a calculated value which is "Field_A+Field_B" and Index called as unique only.

    My Po_odr.set does not have any other setting except "None" for Referential Integrity and I setted as Po_hdr(Parent)(1) ===> (M) Po_item(Child) (1) ---->(1) Products.

    * I like to use the Cascade change/deletes Referential Integrity between Parent and Child and Prevent Change between Po_item and Products joint but If I do it, i cannot use the OnPrintExit events.

    As you can see from the attachments,
    My problems are (1) the first line of product never posted to Products table.
    (2) The 2nd and 3rd line of items are posted / or added together on one of product.
    The Sum of 2nd line and 3rd line Order_Qty is 90. The post result is 90 on the 2nd line from Products table.

    What is wrong my posting field rule?
    Why the field rule does not recognize the Products_id each other?
    Attached Files

  • #2
    Re: Posting Field Rule

    Suggest you remove the products table from the set. This will simplifythings for you. The target table (of your post field rule) does NOT have to be a member of the set.

    Also suggest you attach a copy of your database, or enough of it to permit us to study your field rule in context.

    Comment


    • #3
      Re: Posting Field Rule

      I re read this and suspect that the problem might be the Calculated Product_ID.
      I've had difficulties performing actions on calculated fields in the past.
      As Tom suggests, can we see the Db?
      See our Hybrid Option here;
      https://hybridapps.example-software.com/


      Never ask a Barber if he thinks you need a haircut.

      Comment


      • #4
        Re: Posting Field Rule

        Tom and Ted,

        Thank you.

        I am not sure that the Products_id(Calculated field) causes this problem because when I test with Post Operation, this operation works

        Comment


        • #5
          Re: Posting Field Rule

          On re-reading your original post, John, I now begin to wonder if you're expecting the post field rule to CREATE records in the target Products table? This it will not do. For the post field rule to work the target table must already have a record in place to "receive" the post.

          I won't be responding further, til you supply a working example and instructions for us to follow to see the issue in context.

          Comment


          • #6
            Re: Posting Field Rule

            Tom,

            I am working for Zip file now and I do not expect to create a record in the target table.

            Comment


            • #7
              Re: Posting Field Rule

              Tom

              Here, I attached the Zip file and If you need to see table, From Navigate tool bar -> Untility->Security -> Password 8513

              I hope you can open those table without problem and thank you
              Attached Files

              Comment


              • #8
                Re: Posting Field Rule

                John,

                Can't test your field rules because I can't enter new PO_item records. You have failed to supply supporting tables mentioned or required in other field rules. i.e. ctg_uom and series tables, and their supporting dictionaries and indexes.

                Comment


                • #9
                  Re: Posting Field Rule

                  Tom,

                  Sorry for the trouble.

                  I will make a new zip file.

                  Comment


                  • #10
                    Re: Posting Field Rule

                    Tom,

                    Forget the Posting Field Rule and I gave up to make the Zip files.

                    I want to apply this "Program your own Posting Rules" from Learn A5, http://www.learn alpha.com/Posting/Posting.htm
                    Because (1) I want to add another condition something like "If it printed OK then post it to products table". (2) I found that some of my coding kept hold the posting action. (3) Limitation notes from Learn A5.

                    In this new structure,
                    (1) I am using the Mapped table in order to get the table lookup field.
                    (1-a) the Description is calculated field value as "alltrim(Manuf_Colorno)+" "+Prdctavail->Shape_Id+" "+Prdsurf->Surface_Id+" "+Color_Name " from Mapped table.

                    (2) Problem is the Products_id from Po_Item table does not give me the actual field value. I mean the Products_id value. nor Can not find the products_id from products tables as on below scripts.
                    I am an error trap.

                    Code:
                    [B]Po_item:Products_id.CanWriteField Rule[/B]
                    dim tPoitem as p
                    dim vPrdctId as c
                    dim vOrderQty as n
                    dim vRecNo as n
                    dim tPrdct as p
                    tPoitem = table.get("po_item")
                       vCurVal = a_field_value.value
                       [COLOR="#8b0000"]vPrdctId = a_field_value.value[/COLOR]
                       'vPrdctId = tPoitem.products_id
                    'It will give me the Current Description value so I want to find the Products_di from P_Queue table   
                    'dim tPrdQue as p
                    'dim rPrdQue as n
                    'tPrdQue = table.open("products_queue")
                    'tPrdQue.index_primary_put("Description") 'The Description is calculated field and It did not work 
                    'rPrdQue = tPrdQue.fetch_find(vCurVal) 
                    'if rPrdQue>0 then
                    '    vPrdctId = alltrim(tPrdQue.Products_id)
                    'end if
                    'tPrdQue.close()   
                    
                    tPrdct = table.open("products")
                    tPrdct.index_primary_put("products_id")
                    vRecNo = tPrdct.fetch_find(vPrdctId)
                    if vRecNo<0 then
                        cancel()
                        ui_msg_box("No matching"," Item entry din not find for "+vPrdctId,UI_STOP_SYMBOL)
                        tPrdct.close()
                        end 
                    else ' Test
                      ui_msg_box("matching"," Item entry found for "+vPrdctId,UI_INFORMATION_SYMBOL)  
                    end if
                    tPrdct.close()   
                    end
                    Attached Files

                    Comment


                    • #11
                      Re: Posting Field Rule

                      John, the first line in your script indicates that your script is running in a different "event" than Dr. Wayne uses in his example at learn alpha.com. Are you trying to run the script in the CanWriteField field event in field rules? If so, I strongly suggest that you use the OnSaveRecord record event instead.

                      Comment

                      Working...
                      X