Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Browse will not run from form button

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Browse will not run from form button

    I have created two tables with a form and a custom browse for each one. On each form I placed a button to run the browse. Simple: form/browse; open form/browse; careful to make sure I'm asking for a browse; current selection of records. It won't execute. HOWEVER, if I delete the browse, recreate it EXACTLY like the previous one, it will run. Anybody have any clue as to why?

    I have had to do this to both forms and both browses. The original browse executes correctly from the control panel by double clicking on the browse icon. It just won't execute from the form button until I delete and remake the browse, as noted.

    Using AV9, latest update, XP

  • #2
    Re: Browse will not run from form button

    Interesting twist: I deleted the button which is to cause the browse to run, re-created it, DID NOT SAVE, and the button works, the browse runs. SAVE the form, click the button and it will not run the browse. Any ideas as to why? Just saving the form causes it to fail (apparently).

    Comment


    • #3
      Re: Browse will not run from form button

      Hi ???????,
      Sounds very abnormal to me---never have had this happen in any version/build of Alpha. Which to me indicates either some form of corruption in your form, database, or the Alpha install itself. Problem is, in order to help we have to be able to reproduce the issue and am very doubtful we can.

      Not until this afternoon/evening would I have time to have a remote session with you (if wanted) so that I could see first hand what is happening either to your code or the database files. Let me know if this is something you want to do. (I could not Private Message you....and have no clue as to who I am talking to!! )

      Maybe someone else will chime in that has had similar issues.....
      Mike
      __________________________________________
      It is only when we forget all our learning that we begin to know.
      It's not what you look at that matters, it's what you see.
      Henry David Thoreau
      __________________________________________



      Comment


      • #4
        Re: Browse will not run from form button

        Thanks for your reply.
        Yes, this situation is quite unusual... in all the years I have used A4/5 it has never happened. I suspect that it has something to do with a corrupted file as you mentioned. I just downloaded A5V10 and plan to see if it has any similarities (hope not), and will use V10 going forward. I might even re-install V9 to see if that corrects the problem. Either way, I'll consider this issue closed; I am confident that it is not a problem systemic to A5V9.

        Thanks to all forum participants... without you, we novices could never make it.

        Comment


        • #5
          Re: Browse will not run from form button

          Dear databaser,

          Suggest you zip your database and attach it here, with instructions for us to follow to see what you're seeing. If the data is confidential, make a separate example for us using dummy field values.

          -- tom

          Comment


          • #6
            Re: Browse will not run from form button

            Thank you, Tom, for your response.
            Actually, I don't have anything now that is not working. Whatever I would send to you is in working order and would not reveal anything, as I understand it. After I deleted and re-created the browse and/or button, it worked, though mysteriously. Perhaps you missed my last post where I noted that I was at least going to re-download V9 to see if it cleared up the problem. However, since it is now working, I don't think it would result in anything.
            I would suggest that if I see this occurring on any other table/form/browse that I build, then I will zip it in its 'problem' form and upload it to the forum.
            Thanks, again, for the time that each of you spend in helping.

            Comment


            • #7
              Re: Browse will not run from form button

              I also missed in your posts that you had this solved and are moving forward.

              I guess I didn't read between the lines well enough..

              The normal decorum for the board (although we've been lax lately) is to use your name instead of a 'handle'.

              It makes the board more personal and professional. Please consider using your name instead of databaser (that's probably applicable to most of us...)
              Al Buchholz
              Bookwood Systems, LTD
              Weekly QReportBuilder Webinars Thursday 1 pm CST

              Occam's Razor - KISS
              Normalize till it hurts - De-normalize till it works.
              Advice offered and questions asked in the spirit of learning how to fish is better than someone giving you a fish.
              When we triage a problem it is much easier to read sample systems than to read a mind.
              "Make it as simple as possible, but not simpler."
              Albert Einstein

              http://www.iadn.com/images/media/iadn_member.png

              Comment

              Working...
              X