Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Quick filter problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Guest's Avatar
    Guest replied
    RE: Quick filter problem

    Tom,

    I right-clicked the table, selected open default form, quick filtered, closed form, opened form... and it works. Now the interesting part... I opened my designed form and the results are STILL FILTERED. I clicked show all, selected a different field to filter, closed, opened and IT'S WORKING.

    Now I'm doing this on my "test system" and admittedly I've changed a few settings then restored them, but it was not working when I gave up a couple of hours ago. I will have to wait until tomorrow to try this on the "real system" but hopefully it will respond the same way. I will let you know.

    Thank you,
    Rick

    Leave a comment:


  • Tom Cone Jr
    replied
    RE: Quick filter problem

    Rick,

    Do you get the same results with your tables AND using the DEFAULT FORM for each?

    Suggest you do further testing without using any of your custom forms.

    -- tom

    Leave a comment:


  • Guest's Avatar
    Guest replied
    RE: Quick filter problem

    I meant to include: the main table (order_form) has about 7000 records, the other 3 tables are pretty small and used for drop down menus.

    Rick

    Leave a comment:


  • Guest's Avatar
    Guest replied
    RE: Quick filter problem

    Hi Tom,

    Followed your sequence and it works perfectly in the sample invoice, but will not work in my database. I've been comparing the properties of my table and the sample invoice table and find no real differences... at least that I can see.

    I installed the software on another system and the problem remains. While playing around with my "test system", I tried to compact the database and I get an error message - "Could not update: order_~1 Would you like to continue?"

    I have 4 simple tables and no sets. I've tried to quick filter the other tables and get the same result of all records displayed after the table is closed then opened.

    Thanks,
    Rick

    Leave a comment:


  • Tom Cone Jr
    replied
    RE: Quick filter problem

    Rick,

    I am using A5v4.5 and cannot replicate what you describe.

    If I open the Invoice sample app and then open the default form for the Customer table, I can quick filter the state field to show only those customers from MA (Massachusetts, I guess.) there are only 20.

    If I close the form this closes the table supporting it.

    I then open the invoicing form, browse a few records, and close it.

    I then re-open the default form (or browse) for the customer table again. The filter is still in place.

    I suggest you follow the same sequence to see what you get. Be careful to do it exactly as I've described. let us know whether your filter remains in place when you open the default form for the customer table the second time.

    -- tom

    Leave a comment:


  • Guest's Avatar
    Guest replied
    RE: Quick filter problem

    Hi Edward,

    I checked, there are no filter expressions. There's one table listed (it's a simple one table database) and nothing else on the filter/order tab.

    Thanks,
    Rick

    Leave a comment:


  • Schulzie
    replied
    RE: Quick filter problem

    Hi Rick,

    When you click on .... form,properties,filter/query when your opening form is in design mode, is there a filter or query listed?
    efs

    Leave a comment:


  • Guest's Avatar
    Guest started a topic Quick filter problem

    Quick filter problem

    We have a database I designed years ago running on A5 v4.03 - I just moved it to another computer because of hardware trouble.

    Everything seems to be working fine with one exception... filter (or query) results are not being saved after you exit a form or browse. On the old system, you could filter a table and the results would remain filtered even if you closed the table until you selected "show all". Now, every time you filter, then close and reopen a table, every record is displayed ignoring the filter.

    The old system was running WinME and the new one is XP. I can't think of any other differences. I used the exact same A5 v4.01 CD and then downloaded the v4.03 patch. I'm sure I did the same thing when I originally loaded the software. It's been a long time since I worked on the database design, so I apolgize in advance if I'm missing something obvious.

    Thanks,
    Rick
Working...
X