Alpha Video Training
Results 1 to 7 of 7

Thread: Embedded object not displaying

  1. #1
    Volunteer Moderator Steve Workings's Avatar
    Real Name
    Steve Workings
    Join Date
    Apr 2000
    Location
    The Dreaded Chair
    Posts
    5,604

    Default Embedded object not displaying

    Using 6012-5338

    I have a main menu UX, with a tabbed object and its tab panes for the main menu categories. A few of the "sub menus" are loaded as an embedded object, to be called as an AJAX callback (the default) when the tab pane is selected.

    The embedded objects are more UXs with more menu choices.

    Suddenly (maybe with the advent of this build - I'm not sure) I have one user for whom a couple of the embedded objects do not display. Yet, a couple other embedded objects display just fine.

    I can prove that they load when the tab is selected; I can run onLoadComplete javascript. And I can find the objects and their controls in Chrome inspector. But the contents of the tab simply fail to display - nothing happens at all.

    No console errors.

    This user actually has the same rights that I have (it's their company administrator) and there's no problem with my login.

    I've not added any custom show/hide expressions or anything like that, in fact haven't fiddled with the menu components for quite some time. Of course I've re-saved, re-published, re-evaluated, all with no effect.

    Outta ideas, can't find anything to adjust, so I wondered if anyone else has seen something this and even better, solved it.
    -Steve


  2. #2
    "Certified" Alphaholic peteconway's Avatar
    Real Name
    Peter Conway
    Join Date
    Oct 2005
    Location
    Melbourne, Australia
    Posts
    2,627

    Default Re: Embedded object not displaying

    Is the embedded object likely to be used by more that 40% of users?
    Insanity: doing the same thing over and over again and expecting different results.
    Albert Einstein, (attributed)
    US (German-born) physicist (1879 - 1955)

  3. #3
    Volunteer Moderator Steve Workings's Avatar
    Real Name
    Steve Workings
    Join Date
    Apr 2000
    Location
    The Dreaded Chair
    Posts
    5,604

    Default Re: Embedded object not displaying

    6194-5379 appears to have fixed this. I went with the pre-release to fix the memory leak, but it looks like that's still a problem.
    -Steve


  4. #4
    "Certified" Alphaholic mikeallenbrown's Avatar
    Real Name
    Mike Brown
    Join Date
    Nov 2009
    Location
    United States
    Posts
    1,862

    Default Re: Embedded object not displaying

    Quote Originally Posted by Steve Workings View Post
    I went with the pre-release to fix the memory leak, but it looks like that's still a problem.
    That's disappointing. I'm still hanging out in 5667 hoping the next official update is solid enough to move forward.
    Mike Brown - Contact Me
    Programmatic Technologies, LLC
    Programmatic-Technologies.com
    Independent Developer & Consultant

  5. #5
    Member
    Real Name
    Sean OKelly
    Join Date
    Sep 2015
    Location
    Charleston, WV
    Posts
    234

    Default Re: Embedded object not displaying

    Quote Originally Posted by mikeallenbrown View Post
    That's disappointing. I'm still hanging out in 5667 hoping the next official update is solid enough to move forward.
    Try testing with a panel navigator with tab band controls. I had that problem previously, can't remember which build, and using the panel navigator fixed it. You will have to play with styling to replicate the regular tab control.

  6. #6
    "Certified" Alphaholic mikeallenbrown's Avatar
    Real Name
    Mike Brown
    Join Date
    Nov 2009
    Location
    United States
    Posts
    1,862

    Default Re: Embedded object not displaying

    Sean. I don't know what you're talking about here. Maybe you responded to the wrong post?
    Mike Brown - Contact Me
    Programmatic Technologies, LLC
    Programmatic-Technologies.com
    Independent Developer & Consultant

  7. #7
    Member
    Real Name
    Sean OKelly
    Join Date
    Sep 2015
    Location
    Charleston, WV
    Posts
    234

    Default Re: Embedded object not displaying

    Hi Mike,

    What I'm saying is do a test with a similar setup/layout using panel layout and navigator with panels and tab band control. That way you can somewhat replicate the Tab UI. You can then try to eliminate other issues until you have determined for sure that the issue resides in the Tab UI and not with the embedded ux controls, etc. Primarily a way of debbugging by removing potential issues and rebuilding....

    Of course, I was making the assumption that he was using a Tabbed UI or Tab control in a UX component builder....

Similar Threads

  1. Displaying images in an Embedded Xdialog
    By Finian Lennon in forum Windows Desktop Applications
    Replies: 1
    Last Post: 04-12-2018, 01:59 PM
  2. Embedded objects are not displaying
    By Rajen334 in forum Mobile & Browser Applications
    Replies: 1
    Last Post: 04-08-2016, 10:30 AM
  3. Replies: 1
    Last Post: 05-07-2014, 07:04 PM
  4. Embedded Browse - not displaying all rows
    By canico in forum Alpha Five Version 10 - Desktop Applications
    Replies: 3
    Last Post: 01-30-2013, 02:23 PM
  5. Embedded image in sql table not displaying
    By Garry Flanigan in forum Application Server Version 11 - Web/Browser Applications
    Replies: 1
    Last Post: 03-09-2012, 06:25 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •