Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Map Properties

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Map Properties

    I am new to Alpha and have downloaded the 'Community' version to get some experience in the application. I have worked through the 'Giantkiller' training material which was generally excellent.

    Question - I have created an API code in Google for the Map object and it successfully displays a map of Boston, USA and longitude=0/ latitude=0 in the panel but no other areas when a new address is entered. If I build a UK address & post code and set the object's properties to 'Address' it still displays Boston and longitude=0/latitude=0. I have entered random longitude/ latitude to confirm the correct map can be displayed.

    I assume that one of the map properties are incorrect but cannot identify from the tutorial or help videos.

    Any suggestions would ne greatly appreciated.

    Laurence

  • #2
    If you run the giant-killer sample does the map show different addresses?
    How are you displaying and setting the map address?

    Here's a simple UX using action script to display No 10
    Attached Files
    https://appsbydesign.co.uk/

    Comment


    • #3
      Hi.

      Many thanks for your reply apologies for tardy response.

      Have replicated your suggestion but still have issue. Problem still seems to be that although the post code is constructed in the java action the value is not passed to the map object before it opens. The map object only has longitude and latitude options but no field for the post code entry consequently it never opens the correct map. I have inserted alerts to confirm the address details in the javascript action and when the map page opens. If I manually insert longitude and latitude in the map object it opens correctly to correct area regardless of the coordinates in the javascript action.

      There seems to be a total disconnect between the action and the map opening - what am I misunderstanding?

      I have included some screen shots to show where I am at.

      Many thanks,

      Laurence
      Attached Files

      Comment


      • #4
        Originally posted by laurence sellwood View Post

        There seems to be a total disconnect between the action and the map opening - what am I misunderstanding?
        Check that the runAction is being executed and no javascript errors are being generated.
        Attached Files
        https://appsbydesign.co.uk/

        Comment


        • #5
          The Runaction is being executed as when I manually enter coordinates in the map object and execute the Runaction command the map opens with correct display, The issue still seems to be that the Google component does not convert from address to longitude/ latitude. I have attached some screen shots to illustrate the issue, I do not understand what the javascript console is telling me as this is a completely new area.

          Many thanks.

          Laurence
          Attached Files

          Comment


          • #6
            Originally posted by laurence sellwood View Post
            The issue still seems to be that the Google component does not convert from address to longitude/ latitude
            Yes. the map initial position does not work for me either. Not sure what that does or how it works. Could be an issue with Alpha, Google, or a configuration issue.
            If you are using the Add a marker to the map action however you can select the property Bring marker into view.
            Attached Files
            https://appsbydesign.co.uk/

            Comment

            Working...
            X